Portal    Foro    Buscar    FAQ    Registrarse    Conectarse


Publicar nuevo tema  Responder al tema 
Página 1 de 1
 
 
No Me Funciona La Apertura Del Navegador En Gambas3
Autor Mensaje
Responder citando   Descargar mensaje  
Mensaje No Me Funciona La Apertura Del Navegador En Gambas3 
 
Buenos días, hace unos días instalé por primera vez gambas3, seguí un ejercicio del libro que me compré, pero cuando quiero ejecutar un ejercicio, y llama al navegador, no se me abre.

Me pueden ayudar? Gracias.
 



 
Marcuegal - Ver perfil del usuarioEnviar mensaje privado 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: No Me Funciona La Apertura Del Navegador En Gambas3 
 
Echa un vistazo a este ejemplo. Necesitas "gb.desktop" para este trabajo. Ver fotos adjuntas (perdón en inglés).

browser2browser1

OpenBrowser-0.0.1.tar.gz
Descripción:  
Descargar
Nombre del archivo: OpenBrowser-0.0.1.tar.gz
Tamaño: 11.36 KB
Descargado: 105 veces

 



 
cogier - Ver perfil del usuarioEnviar mensaje privado 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: No Me Funciona La Apertura Del Navegador En Gambas3 
 
Marcuegal escribió:  
Buenos días, hace unos días instalé por primera vez gambas3, seguí un ejercicio del libro que me compré, pero cuando quiero ejecutar un ejercicio, y llama al navegador, no se me abre.

Me pueden ayudar? Gracias.


Hola y bienvenido

¿Nos puedes decir también qué versión de gambas estás ejecutando y tu sistema operativo? Es información relevante, ya que podría ser algún bug de alguna versión antigua...

Saludos
 




===================
Jesús Guardón

Por favor, usemos el corrector ortográfico antes de pulsar el botón "Enviar".

"uo ǝs ʇɐu pıɟıɔıן ɐdɹǝupǝɹ ɐ dɹoƃɹɐɯɐɹ, soןo ɥɐʎ bnǝ dɹodouǝɹsǝןo"
 
jguardon - Ver perfil del usuarioEnviar mensaje privado 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: No Me Funciona La Apertura Del Navegador En Gambas3 
 
Bienvenido Marcuegal.


Cogier ha entendido tu pregunta a la primera. Pero esto no es fácil y no siempre será así.

Tienes que plantear un poco mejor las preguntas para que podamos ayudarte. Por ejemplo.

-  ¿ Qué intentas hacer ?. (Que hace tu código).

-  ¿ Cómo lo haces ?.  Básicamente. Copia y pega tu código si no es grande.

-  ¿ Qué hace gambas ?. ¿ Qué respuesta te da al ejecutar tu código ?. Mensaje de error.

Paso a paso.

Saludos
 




===================
Gambas Básico
"No es un bug, es una característica no documentada"
 
Shell - Ver perfil del usuarioEnviar mensaje privadoVisitar sitio web del usuario 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: No Me Funciona La Apertura Del Navegador En Gambas3 
 
Shell escribió:  
Bienvenido Marcuegal.


Cogier ha entendido tu pregunta a la primera. Pero esto no es fácil y no siempre será así.

Tienes que plantear un poco mejor las preguntas para que podamos ayudarte. Por ejemplo.

-  ¿ Qué intentas hacer ?. (Que hace tu código).

-  ¿ Cómo lo haces ?.  Básicamente. Copia y pega tu código si no es grande.

-  ¿ Qué hace gambas ?. ¿ Qué respuesta te da al ejecutar tu código ?. Mensaje de error.

Paso a paso.

Saludos



Gracias por vuestras respuestas.

Compré el libro de gambas WebForm, Desarrollo de aplicaciones web con gambas

Tuve muchos problemas para instalar el entorno Linux en mi W10, utilicé la instalación que viene en la tienda de microsoft.
No he utilizado nunca Linux, y es posible que no haya hecho algo bien.

Pero en el libro, creo que no me describe bien todos los pasos que debo seguir.
El ejercicio en cuestión es hacer que se abra un navegador y que ponga "HOLA MUNDO", pero no soy capaz de que cuando ejecuto el programa, abra dicho navegador.

Yo he programado en Access. Cuando conocí de la existencia de Gambas3, me ilusioné bastante. Pero tengo tanto desconocimiento del entorno, y que me fallan algunas cosas, pues estoy viendo abajo. Pero que seguro será por culpa mia, al no conocer bien linux.

Saludos.
 



 
Marcuegal - Ver perfil del usuarioEnviar mensaje privado 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: No Me Funciona La Apertura Del Navegador En Gambas3 
 
Marcuegal escribió:  
[

Compré el libro de gambas WebForm, Desarrollo de aplicaciones web con gambas

Tuve muchos problemas para instalar el entorno Linux en mi W10, utilicé la instalación que viene en la tienda de microsoft.
No he utilizado nunca Linux, y es posible que no haya hecho algo bien.


Hola de nuevo

El autor del libro es miembro de este foro y seguro que puede ayudarte mejor, pero en mi opinión, quizás empezar a programar en gambas por la parte "web" (llamémoslo así) es un poco precipitado. Yo hubiera empezado con programas sencillos de escritorio para familiarizarme con el lenguaje en lo más básico y después explorar otras opciones como Webforms.

Otra cosa importante, creo yo, es que Linux dentro del entorno WSL2 no creo que llegue a ser tan estable y fiable como un Linux nativo. Si tienes oportunidad, prueba a instalar Linux en un PC que tengas de sobra o incluso puedes instalarlo junto a W10 y disponer de doble arranque, pero es algo que sólo tu puedes decidir en base a los riesgos.

Volviendo al tema, si no recuerdo mal, creo que gambas crea un servidor web "al vuelo" cuando trabajas con webforms para poder probar los desarrollos. Es decir, cada vez que ejecutas el código. Pero luego, para llevarlo a un entorno de producción, es el programador el que tiene que crear ese entorno web instalando Apache2 y lo que proceda.

En definitiva, sin ver el código, es complicado saber qué está pasando. Hay una opción en el menú para empaquetar el código fuente de tu proyecto y poder enviarlo comprimido, si lo consideras conveniente, de manera que alguien más pueda probarlo y averiguar el problema.

Saludos
 




===================
Jesús Guardón

Por favor, usemos el corrector ortográfico antes de pulsar el botón "Enviar".

"uo ǝs ʇɐu pıɟıɔıן ɐdɹǝupǝɹ ɐ dɹoƃɹɐɯɐɹ, soןo ɥɐʎ bnǝ dɹodouǝɹsǝןo"
 
jguardon - Ver perfil del usuarioEnviar mensaje privado 
Volver arribaPágina inferior
Responder citando   Descargar mensaje  
Mensaje Re: No Me Funciona La Apertura Del Navegador En Gambas3 
 
jguardon escribió:  
Marcuegal escribió:  
[

Compré el libro de gambas WebForm, Desarrollo de aplicaciones web con gambas

Tuve muchos problemas para instalar el entorno Linux en mi W10, utilicé la instalación que viene en la tienda de microsoft.
No he utilizado nunca Linux, y es posible que no haya hecho algo bien.


Hola de nuevo

El autor del libro es miembro de este foro y seguro que puede ayudarte mejor, pero en mi opinión, quizás empezar a programar en gambas por la parte "web" (llamémoslo así) es un poco precipitado. Yo hubiera empezado con programas sencillos de escritorio para familiarizarme con el lenguaje en lo más básico y después explorar otras opciones como Webforms.

Otra cosa importante, creo yo, es que Linux dentro del entorno WSL2 no creo que llegue a ser tan estable y fiable como un Linux nativo. Si tienes oportunidad, prueba a instalar Linux en un PC que tengas de sobra o incluso puedes instalarlo junto a W10 y disponer de doble arranque, pero es algo que sólo tu puedes decidir en base a los riesgos.

Volviendo al tema, si no recuerdo mal, creo que gambas crea un servidor web "al vuelo" cuando trabajas con webforms para poder probar los desarrollos. Es decir, cada vez que ejecutas el código. Pero luego, para llevarlo a un entorno de producción, es el programador el que tiene que crear ese entorno web instalando Apache2 y lo que proceda.

En definitiva, sin ver el código, es complicado saber qué está pasando. Hay una opción en el menú para empaquetar el código fuente de tu proyecto y poder enviarlo comprimido, si lo consideras conveniente, de manera que alguien más pueda probarlo y averiguar el problema.

Saludos



Muchas gracias por tu ayuda. Voy a intentar hacer una instalación nativa de linux. Creo que me irá mejor.

Saludos a todos.
 



 
Marcuegal - Ver perfil del usuarioEnviar mensaje privado 
Volver arribaPágina inferior
Mostrar mensajes anteriores:    
 
OcultarTemas parecidos
Tema Autor Foro Respuestas último mensaje
No hay nuevos mensajes Mi Primer Navegador En Gambas3 hostinglobal Controles/Librerías/Componentes 0 Domingo, 09 May 2010, 04:18 Ver último mensaje
hostinglobal
No hay nuevos mensajes Necesito Ayuda Con Un Navegador vfranco Controles/Librerías/Componentes 1 Lunes, 19 Julio 2010, 05:27 Ver último mensaje
hostinglobal
No hay nuevos mensajes Crear Navegador Radietor General 27 Martes, 09 Noviembre 2010, 23:03 Ver último mensaje
Invitado
No hay nuevos mensajes Navegador Safari Shell Off-topic 1 Sabado, 25 Abril 2020, 11:27 Ver último mensaje
Shell
 

Publicar nuevo tema  Responder al tema  Página 1 de 1
 

Usuarios navegando en este tema: 0 registrados, 0 ocultos y 1 invitado
Usuarios registrados conectados: Ninguno


 
Lista de permisos
No puede crear mensajes
No puede responder temas
No puede editar sus mensajes
No puede borrar sus mensajes
No puede votar en encuestas
No puede adjuntar archivos
Puede descargar archivos
No puede publicar eventos en el calendario



  

 

cron